Joomla! extensions developer

Pre-Sales FAQ

Why should I choose Twentronix?

We provide awesome Joomla extensions and support for a fair price. Our extensions are user friendly, work great and looks great. We aim for the top and are fully dedicated to Joomla extensions development. Besides that we like to keep it honest. No hidden fees, encrypted code, domain limitations or other unfair stuff.

What is the license for your extensions?

All our extensions are released under the terms of the GNU General Public License, version 3. This license allows you to install our extensions on an unlimited number of websites. Moreover the extensions will continue to function after the expiration of your subscription. Our extensions are Open-Source, just like Joomla!

Can I use your extensions after my subscription expires?

Of course! Our extensions will remain fully functional after your subscription has expired. You only have to renew your subscription if you would like to regain access to downloads, updates and support. The documentation is publicity accessible, so you can still access it after your subscription has expired.

Can I use your extensions on multiple websites?

Yes! Our extensions are released under the terms of the GNU General Public License, version 3. This license allows you to install the extensions on an unlimited number of websites.

Are subscriptions automatic renewed?

No, subscriptions are NOT automatic renewed. Your subscription automatically ends after your subscription period. However it's advised to renew your subscription before it's expired, so you can get a discount: we love to reward loyal customers!

What are the minimum requirements?

Cookie Confirm

  joomla 25 joomla 3x
Joomla! and PHP See version compatibility
MySQL 5.0.4 + 5.1 +
Apache 2.x + 2.x +
HTML W3C Valid W3C Valid
Important!
We can only provide support for setups which meet the above requirements and do NOT have modified Joomla core or extension files.

Twentronix Shortcuts

  joomla 25 joomla 3x
Joomla! and PHP See version compatibility
MySQL 5.0.4 + 5.1 +
Apache 2.x + 2.x +
Browser Firefox 4+, Google Chrome 5+, Opera 10+, Safari 4+, IE 8+
Keyboard Latin-script keyboard
Important!
We can only provide support for setups which meet the above requirements and do NOT have modified Joomla core or extension files.

Can I use your extensions with PHP 5.2.x or lower?

You can NOT use our extensions with PHP 5.2.x or lower. PHP 5.2.x or lower is end-of-life, unsafe, slow and even not supported by PHP itself. It's highly recommended to update to PHP 5.3. Joomla! also advise this and it's even mandatory for Joomla! 3.0 and higher.
Our extensions are not tested with those old PHP versions and therefore it's highly likely that they wouldn't work correctly. To prevent such issues, there's a check in our extensions which checks for the minimum requirements before installation and execution. So it's impossible to install and use our extensions on servers which doesn't meet the mimimum PHP requirements.

Can I use your extensions on Joomla 1.5?

We are sorry that's not possible. We do not support Joomla 1.5 for various reasons:

  1. Joomla 1.5 is end-of-live.
    This means that this release is even not supported anymore by Joomla itself. Joomla will not release security fixes for Joomla 1.5. By using such an old Joomla version you're sitting ducks for hackers. Therefore we highly recommend to migrate Joomla 1.5 websites to a supported Joomla version.
  2. No Joomla core bugfixes.
    Because of the fact that Joomla 1.5 is end-of-life and Joomla will not release patches to fix bugs, so we can not guaranteed the extension will work properly.
  3. It would take a LOT of time to make our extensions compatible with Joomla 1.5.
    For example the FOF framework which we use doesn't support Joomla 1.5 (due to the reasons mentioned above). We would basically have to rewrite the whole extension. We rather use this time to improve the extension so much more people can benefit of it.

The latest Joomla versions also offer new great features and are supported by almost all extension developers.

Can I use your extensions on non-Joomla sites?

We are sorry that's not possible. Our extensions are only compatible with Joomla!. You can NOT use them on other Content Management Systems such as Wordpress or Drupal. This is because they are build upon the Joomla framework.

Can I edit the code?

Yes! Our extensions are fully open source and the code is NOT encrypted in any way. No use of Zend Optimizer or Ioncude. You are free to change the code to your likings. However, if you alter the extensions files, we can no longer provide support on any problems you encounter. Also if you update or reinstall the extension, all changes you made will be lost. Therefore it's better to overrule functionality via template overrides or custom plugins. For changes in styling it is best to overrule style classes through the css stylesheet of your template or by adding a custom stylesheet.

Why are not all your extensions free, why do I need to pay?

Without the small fee, we couldn't provide you the great extensions and support. By paying for your subscription we can continue to work on the development of our extensions and provide you excellent support.

Where can I find more information?

You can check the documentation, Privacy Policy & TOS, License and Refund Policy for more information. You can also contact us for pre-sales questions or submit a ticket if you'll need support.

Jurian Even

About the author

Jurian Even is the founder of Twentronix, is passionate about Joomla and earns a living with developing Joomla extensions. He loves technical challenges and gets a thrill of producing effective and elegant solutions.

This content is blocked because it needs cookies to function. To view this, please...

Cookie Confirm

Comply to the Cookie Law with Cookie Confirm: the ultimate cookie control extension for Joomla! It's easy to setup and developed with usability, functionality and good graphics in mind.

Subscribe Now

Feeling Social?

Join us on the social media networks to keep up-to-date and enjoy exclusive offers!

Twitter Facebook